ID:1
加载中 ...
首页 > 指标公式 > 飞狐公式 > 正文

期货15分钟kdj参数最佳设置:五龙起舞(源码、副图、飞狐、贴图)-飞狐公式-股票公式指标网

2020-04-02 09:54:27 来源:

以下是五龙起舞(源码、副图、飞狐、贴图)(无源码的请下载附件导入)

五龙起舞(源码、副图、飞狐、贴图)

使用经典CCI/KDJ/RSI/WR/MDI五大指标展现股价纪律:
 


TYP:=(H+L+C)/3;   
CCIO:=(TYP-MA(TYP,9))/(0.015*AVEDEV(TYP,9)),NODRAW,Precision1;
FILLRGN(CCIO>150,CCIO,150),ColorFFFF00;   
FILLRGN(CCIO<-200,CCIO,-200),COLORA69AFA;   
FILLRGN(CCIO<>150,150,-200),COLOR000000;
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;  
KO:=SMA(RSV,N1,1),Precision1;
DK:=SMA(KO,N2,1),Precision1;
JO:=3*KO-2*DK,Precision1;
FILLRGN(JO>88,JO,88),COLOR20E839;   
FILLRGN(JO<12,JO,12),COLORRED;   
DRAWBAND(88,0,12,0);{地区无色}
CCI:ccio,ColorYellow,Precision1,LINEDOT;DRAWTEXT(ISLASTBAR,CCI,'       CCI'),ColorYellow,LINETHICK16;
J:JO,LINETHICK1,ColorWhite,Precision1;DRAWTEXT(ISLASTBAR,J,' J'),ColorWhite,LINETHICK16;
K:KO,COLORFF00FF,Precision1,nodraw;
D:DK,ColorGreen,Precision1,nodraw;
A2:=BARSLAST(REF(CROSS(KO,DK),1));
B2:=REF(C,A2+1)>C AND REF(KO,A2+1)<KO AND CROSS(KO,DK),coloryellow;
C2:=BARSLAST(REF(CROSS(DK,KO),1));
D2:=REF(C,C2+1)<C AND REF(KO,C2+1)>KO AND CROSS(DK,KO);
KDJ底背:=B2>0;
DRAWTEXT(B2>0,k*1.1,'   K底背'),COLORFF00FF;DRAWICON(B2>0,k*1.1,1);
KDJ顶背:=D2>0;DRAWTEXT(D2>0,k*1.1,'K顶背'),COLORFFCC66;
DRAWTEXT(CROSS(K,D),k*0.95,' K金'),ColorYellow;
RSI:SMA(MAX(c-REF(c,1),0),6,1)/SMA(ABS(c-REF(c,1)),6,1)*100,Precision0,COLORred;DRAWTEXT(ISLASTBAR,RSI,'       RSI'),ColorRed;
R1:=SMA(CCIO,3,1);   
D1:=SMA(R1,3,1);   
J1:=3*R1-2*D1;   
RR1:=EMA(J1,5);   
RR2:=REF(RR1,1);
RR:=RR1>RR2;
买:=RR AND NOT(REF(RR,1)) AND (RR1<-130 AND RR1<-130),LINETHICK0;DRAWTEXT(买,CCIO*0.95,'↑B'),LINETHICK17,ColorRED;
卖:=REF(RR,1)=1 AND NOT(RR) AND RR1>100,LINETHICK0;DRAWTEXT(卖,CCIO*0.95,'↓S'),LINETHICK16,ColorGreen;
tja:=(2*C+H+L)/4;
tjb:=LLV(L,9);{9-34D}
tja1:=HHV(H,9);{9-34D}
BX:=EMA((tja-tjb)/(tja1-tjb)*100,8);
BX1:=EMA(BX,5);
{STICKLINE(BX-BX1>0,BX,BX1,8,1),COLORRED;
STICKLINE(BX-BX1<0,BX,BX1,8,1),COLOR00FF00;}
DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
短线多空:PARTLINE(bX>BX1,0),COLOR0000FF,LINETHICK2;DRAWTEXT(ISLASTBAR,短线多空,' 短线多空'),ColorBlue,LINETHICK15;
PARTLINE(BX<=BX1,0),ColorGreen,LINETHICK2;
DRAWTEXT(CROSS(BX,BX1),BX*0.95,' ↑▲反向'),ColorYellow;
TR1:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HD:=H-REF(H,1);
LD:=REF(L,1)-L;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),14,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),14,1);
PDI:=DMP*100/TR1;
STICKLINE(RSI>88,0,50,0.5,0),ColorGreen;
DRAWTEXT(RSI>88,50*1.1,'!RIS'),ColorGreen;

五龙起舞(源码、副图、飞狐、贴图)


“老钱庄财经”的新闻页面文章、图片、音频、视频等稿件均为自媒体人、第三方机构发布或转载。如稿件涉及版权等问题,请与

我们联系删除或处理,客服邮箱991398077@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同

其观点或证实其内容的真实性。

  • 声音提醒
  • 60秒后自动更新