ID:1
加载中 ...
首页 > 指标公式 > 大智慧公式 > 正文

股票做长线的技巧:大聪明顺势598主图指标公式

2019-12-31 23:13:14 来源:

--> DRAWGBKLAST(C0,STRIP(RGB(0,0,0),RGB(0,0,180),1));
{MY指标公式网http://www.myzhibiao.com/}
STICKLINE(CLOSEOPEN,HIGH,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(OPEN=CLOSE,HIGH,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR006600;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,8,0) ,COLOR000466;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,7,0) ,COLOR000499;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,5,0) ,COLOR0003bb;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,3,0) ,COLOR0002dd;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,1,0) ,COLOR0001ff;
{my指标公式网http://www.myzhibiao.com/}
LC:=REF(C,1);
卖黄金:((SMA(MAX((C - LC),0),3,1) / SMA(ABS((C - LC)),3,1)) * 100),LINETHICK0;
STICKLINE(CROSS(80,卖黄金) AND CO,H,L,2,0),COLOR00ffff,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND CO,C,O,12,0 ),COLOR007777,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND CO,C,O,8,0 ),COLOR009999,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND CO,C,O,6,0 ),COLOR00BBBB,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND CO,C,O,4,0 ),COLOR00DDDD,LAYER0;
STICKLINE(CROSS(80,卖黄金) AND CO,C,O,2 ,0 ),COLOR00ffff,LAYER0;
ma5:EMA(C,5),LINETHICK0;
PARTLINE(ma5,(ma5REF(ma5,1))-1,rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK2,LAYER6;
VAR1:=(3*CLOSE+HIGH+LOW+OPEN)/6;
A1: (EMA(VAR1,2)+EMA(VAR1,3)+EMA(VAR1,5)+EMA(VAR1,8)+EMA(VAR1,13))/5,COLORff9900;
A2: EMA(A1,2),COLORff9900;
A3: EMA(A2,2),COLORff9900;
A4: EMA(A3,2),COLORff9900;
A5: EMA(A4,2),COLORff9900;
A6: EMA(A5,2),COLORff9900;
A7: EMA(A6,2),COLORff9900;
A8: EMA(A7,2),COLORff9900;
A9: EMA(A8,2),COLORff9900;
A10: EMA(A9,2),COLORff9900,LINETHICK2;;
PARTLINE(A1,A1REF(A1,1)),COLOR00ffff;
PARTLINE(A2,A2REF(A2,1)),COLOR00ffff;
PARTLINE(A3,A3REF(A3,1)),COLOR00ffff;
PARTLINE(A4,A4REF(A4,1)),COLOR00ffff;
PARTLINE(A5,A5REF(A5,1)),COLOR00ffff;;
PARTLINE(A6,A6REF(A6,1)),COLOR0ffff0;
PARTLINE(A7,A7REF(A7,1)),COLOR0ffff0;
PARTLINE(A8,A8REF(A8,1)),COLOR0ffff0;
PARTLINE(A9,A9REF(A9,1)),COLOR0ffff0;
PARTLINE(A10,A10REF(A10,1)),COLOR0ffff0;;
五日乖离率:=(c-MA(C,5))/MA(C,5)*100;
拾八日乖离率:=(c-MA(C,18))/MA(C,18)*100;
JC:=cross(0,五日乖离率) and 拾八日乖离率ref(拾八日乖离率,1) and EMA(C,10)ref(EMA(C,10),1) ;
减仓:=filter(JC,10);
drawtext(减仓,high*1.03,'减仓'),color00ffff,linethick2;
A74:=MA(CLOSE,20);
A75:=(CLOSE MA(CLOSE,5));
A76:=(MA(CLOSE,5) MA(CLOSE,10));
A77:=(CLOSE MA(CLOSE,10));
A78:=(MA(CLOSE,5) MA(CLOSE,20));
A79:=(CLOSE MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(vol,5);
V2:=MA(VOL,10);
IF BARSTATUS=2 and c200 and ((CROSS(AVX,1) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股的量能抱负,有显着走强迹象,可以思量中线出场到场,仓位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(AVX,1) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股固然走势趋强,但量能还显不敷,可以思量短线出场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(AVX,1) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股量价共同精良,但相对别的股票并没有显着走强,可以思量短线出场,仓位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(AVX,1) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,40,'该股形态尚可,但量能不敷,股票也未完全走强,可以短线到场,仓位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(1,AVX) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股形态变坏,但走势相对别的股票尚可,重仓者减持泰半,清仓者可以张望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(1,AVX) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股随大盘一起下跌,程显着缩量走势,思量到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(1,AVX) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股放量下跌,走势显着偏弱,离场张望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((CROSS(1,AVX) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股缩量下跌,走势偏弱,离场张望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股形态精良,强势显着,量能富足,可以继承持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股上行趋势稳定,强势依然,但量能开始转弱,留意风险。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股仍旧具备上涨潜力,但股性偏弱,可思量减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股走势趋弱,量能不敷,减持大部门筹码。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股形态不佳,留意成交量的变革,但现在不得当到场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTABS(12,10,'该股趋势不明,股价偏弱,留意量能变革,现在不宜到场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股有走强迹象,但量能不敷,趋势不明,不得当操纵。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and ((((AVX 1) AND (REF(AVX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTABS(12,10,'该股走势太弱,没有到场代价。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and (CROSS(AVX,1) AND (V1 = V2)) THEN
DRAWTEXTABS(12,10,'大盘量能抱负,有显着走强迹象,可以思量中线出场到场,仓位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and (CROSS(AVX,1) AND (V1 = V2)) THEN
DRAWTEXTABS(12,10,'如前期颠末一轮下跌,此时为最佳买点,但假如前期有过一段涨幅则参与需审慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and (CROSS(AVX,1) AND (V1 V2)) THEN
DRAWTEXTABS(12,10,'大盘固然走势趋强,但量能还显不敷,假如前期颠末一轮下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and (CROSS(AVX,1) AND (V1 V2)) THEN
DRAWTEXTABS(12,10,'可以思量短线出场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c200 and (CROSS(1,AVX) AND (V1 = V2)) THEN
DRAWTEXTABS(12,10,'大盘形态走坏,重仓者可以减去大部门仓位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and (CROSS(1,AVX) AND (V1 V2)) THEN
DRAWTEXTABS(12,10,'大盘缩量调解,留意风险,短线清仓张望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and (((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) THEN
DRAWTEXTABS(12,10,'大盘走势精良,量能抱负,可以继承持有强势股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c200 and (((AVX = 1) AND (REF(AVX,1) 0)) AND (V1 V2)) THEN
DRAWTEXTABS(12,10,'大盘形态精良,但量能稍显不敷,随时预备减仓。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c200 and (((AVX 1) AND (REF(AVX,1) 0)) AND (V1 = V2)) THEN
DRAWTEXTABS(12,10,'大盘趋势不明,留意成交量变革,现在不相宜出场。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c200 and (((AVX 1) AND (REF(AVX,1) 0)) AND (V1 V2)) THEN
DRAWTEXTABS(12,10,'大盘趋势向下,量能萎缩,不得当出场。 '),COLOR00FF00,LINETHICK3;
{MY指标公式网http://www.myzhibiao.com/}
p:=BARSLAST(DISPSTATUS=1)+1;
{MY指标公式网http://www.myzhibiao.com/}
ah:=hhvall(hhv(h,P));
al:=llvall(llv(l,P));
nnl:=DISPSTATUS=2;
ahl:=ah-al;
q191:=al+ahl*0.191;
q382:=al+ahl*0.382;
q500:=al+ahl*0.500;
q618:=al+ahl*0.618;
q809:=al+ahl*0.809;
DRAWTEXT(nnl,ah,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLOR0000ff;
DRAWTEXT(nnl,q809,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,q618,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,q500,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLOR00ffff;
DRAWTEXT(nnl,q382,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,q191,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,al,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLOR00ff00;
DRAWTEXT(nnl,ah*0.998,'最高.'+ah+''),ALIGN0,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,q809,'80.9%.' +q809+''),ALIGN0,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,q618,'61.8%.'+q618+''),ALIGN0,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,q500,'50%.'+q500+''),ALIGN0,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,q382,'38.2%.'+q382+''),ALIGN0,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,q191,'19.1%.'+q191+''),ALIGN0,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,al*1.01,'最低.'+al+''),ALIGN0,VALIGN2,Color0047FF,LINETHICK1; 大聪明顺势598主图指标公式的选股公式如下:

“老钱庄财经”的新闻页面文章、图片、音频、视频等稿件均为自媒体人、第三方机构发布或转载。如稿件涉及版权等问题,请与

我们联系删除或处理,客服邮箱991398077@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同

其观点或证实其内容的真实性。

  • 声音提醒
  • 60秒后自动更新